AnsweredAssumed Answered

IE Browser Compatability and Geopoint Calculation with Public Surveys made in Connect

Question asked by Kdunk24 on May 17, 2017
Latest reply on Jul 19, 2017 by Kdunk24

I am making an alarm registration form in connect, publishing to AGOL, sharing it with everyone, and using the web address in Connect through "Open in Survey123 Web App" for citizens to fill out and submit. I am testing and finding that my form does not display in internet explorer 11.00.9600.18666. This System requirements—Survey123 for ArcGIS | ArcGIS says it should be fine but has anyone experienced this issue? The form attempts to load but eventually I receive a "arcgis.com is not responding due to a long-running script" and when I stop the script (an option in the pop up box) the form appears but is not complete. Drop downs are missing for example.

 

Also I am trying to calculate a geopoint for the form by following this blog: Calculations on Geopoints and have success in the Connect form preview but when viewing in chrome\firefox (because IE does not work) the calculate does not work and when I submit the form it highlights the geopoint box as needing to be answered. I have it marked as read only and NOT required just as in the blog post. Any ideas on the issue?

 

Another note- I have a calculation that displays fine in the connect form preview but not completely correct in the Survey123 Web App link.

Here is the calculation: if(${Confirm_email}=${Email}, ${Confirm_email}, '<font color="red">Submitted Emails do not match! Please review your email address!</font>')

Here is the result in the browser:

this isn't a problem until the calculation returns a false and the gray box displays the "<font color="red......" and then below that is the correct display.

 

Any help on any of these will be appreciated!!

Outcomes