gilbertorm83@gmail.com

Errors when trying to use appbuilder 2.2 web print widget

Discussion created by gilbertorm83@gmail.com on May 15, 2017
Latest reply on May 24, 2017 by gilbertorm83@gmail.com

Hello!

 

I'm having trouble using the print widget, contained in appbuilder 2.2 web. I'm getting the following errors every time I click the "print" button:

 

1) There was an error executing the tool. Export Web Map Task Job ID: xxxxxx: "defaultBasemap_0": Could not connect to map server at http://services.arcgisonline.com/ArcGIS/rest/services/World_Topo_Map/MapServer. An error occurred while executing (Export Web Map). An error occurred while executing (Export Web Map Task).


2) Unabled to load http://medeia.kappa.sede.intranet.fepam/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%20Web%20Map%20Task/execute status: 0 (Displayed by the widget's question mark);


POST http://medeia.kappa.sede.intranet.fepam/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%20Web%20Map%20Task/execute net::ERR_CONNECTION_RESET (Displayed on the chrome console).


I tried to use the esri print service, but the same problem occurs. I've tried it in many ways, but nothing works. I even asked the network administrator to release the proxy to see if it was not being blocked by the proxy, but I did not succeed either.

My scenario is this: all application code generated by web appbuilder 2.2, is inside the iro wwwroot folder of my local machine. The portal and the arcgis server, are on the server called "medeia".

 

Esri URL I tried to use: https://utility.arcgisonline.com/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%20Web%20Map%20Task 

 

 

Attached is my print widget.

Thanks for any help, as I have no idea how to correct the problem.

 

Thank you!
Gilberto.

Attachments

Outcomes