AnsweredAssumed Answered

map layers not displaying

Question asked by s.groff on May 10, 2017
Latest reply on Jun 9, 2017 by OEvans-esristaff

Hi there - I've created a story map (tabbed map series) that is looking at various demographics for a county that contains 973 census block groups. Each tab has a choropleth map focused on data by census block groups for a single attribute so each layer has 973 features within it. At first, I tried creating all the layers within one map and then for each story map tab, editing the tab to display or hide various layers, as I had read this is the best method for performance. This has led to some wonky display issues. Sometimes a layer will display and other times it won't. When I check my story map via My Stories, sometimes it does not show any problems with the layers/maps within the story map despite the fact that no data are showing and yet other times it will say there is an error with certain layers. I'm trying an alternative method to create a single map for each layer (which will then represent one tab in the story map) but so far this isn't fixing anything. I've tried saving the layers once symbolized; also tried setting a refresh rate (0.1 minutes). I've also tried viewing the story map with an https vs. http and that hasn't changed anything consistently. There doesn't seem to be rhyme or reason as to which layer will display and which won't. This story map is not public yet because it has to go through a process within our county prior to sharing, but I can't finalize it with these issues. Any advice? Thank you!

 

EDITED TO ADD: Also, sometimes the data will appear within the map (say, if I've symbolized the block groups by white race) and then it will disappear if I click on it to view the pop-up.

Outcomes