AnsweredAssumed Answered

How to force Web AppBuilder to use HTTP (not HTTPS)?

Question asked by stevel on Nov 27, 2016
Latest reply on Nov 28, 2016 by rscheitlin

I have an out-of-the-box instance of ArcGIS Web AppBuilder developer edition - the startup.bat file is unmodified and includes the lines:

 

REM open the url in browser
START http://%FQDN%:%port%/%wabVirtualPath%
EXIT 0

However, when I start a new session on my PC, it runs as https://localhost:3344/webappbuilder - even if I forcibly change the URL to http:// it immediately reverts to https://

 

This is causing a problem when I try to access ArcGIS Server REST endpoints which are not served via https.

For example, when trying to add a sample layer via the Local Layer Widget I get an error message about insecure content:

 

https problem


I'm working in a corporate environment and don't have the option of serving my local layers via HTTPS, so I'd like to know whether it's possible to force Web AppBuilder to run on HTTP.

Outcomes