AnsweredAssumed Answered

JS API Error upgrading to 3.16+ from 3.11

Question asked by TSI-AR on Nov 1, 2016
Latest reply on Nov 4, 2016 by TSI-AR

I'm developing an App based on the Tax Parcel Viewer solution: Tax Parcel Viewer | ArcGIS for Local Government .  My variant has been running using JS API 3.11.

I now need to add a multi-property report, and FeatureTable capability as used in
https://developers.arcgis.com/javascript/3/jssamples/featuretable_custommenu.html is an ideal solution. The featureTable functionality requlred is not available in 3.11, but is in 3.16+.

I've tried to get my variant of TaxParcelViewer running under 3.16, 3.17, and 3.18.

In all cases I get the following error: Type Error: a.id.match is not a function.

This is at map.addLayer on line 457, which runs without error under 3.11.

 

 

Any suggestions on how to resolve this error?

 

Chuck

Outcomes