AnsweredAssumed Answered

Import from Excel causing data column loss - can't plot data

Question asked by Geobrett on Oct 31, 2016
Latest reply on Nov 1, 2016 by dkwiens

Hi all,

 

When it rains, it pours... now a second issue has arisen - of course when there is a deadline to meet.

 

I am trying to import an Excel spreadsheet to plot field measurement (geology). I get:

  1. random 'database' error messages, especially trying to add a .xlsx worksheet;
  2. after clicking 'Display XY data' the dialog opens, but I only see the first few columns and not the data columns
  3. sometimes the import has partially worked, but some columns are missing.
  4. despite what  happens in 2., when I export the data to a layer I can see the full table, with all the data, but while using 'Selecting by Attributes' shows the data columns, always produces an SQL syntax error window when I've done nothing different from before. I figured it is simply not seeing the columns. When the data columns have been present, the Selection by Attribute works.

 

I have tried renaming, saving as .xls, partially recompiling the data in a new spreadsheet, but nothing is working. I had frozen panes and thought this may be a problem when saving the spreadsheet, but have found that it makes no difference. I really need this to work in a hurry, so i anyone can assist I'll be very grateful.

 

I have attached grabs of the dialogs and an extracts (.xlxs and .xls) from the spreadsheet. The extracts also repeat the issue. For some reason the column order in the Table has changed too, I just noticed! The first two data columns should be to the far right of the last column 'Lineation'.

 

Thanks in advance.

Outcomes