Why does my raster image fade out after creating pyramids?

953
8
10-31-2016 07:54 AM
BrettDavies
New Contributor II

Hi all.

I just created pyramids for several large Worldview detests to speed up display, and now they will only display when zoomed to raster resolution. What gives? The images are in TIFF format (with a world file of course). 

I have attached three two images (despite the notes re. file size and total number allowed, the 'Attach' file would let me load a 248KB file!!.) of approximately the same area: the first zoomed out (showing one of six images that doesn't show the problem - that was exported from Global Mapper and imported into ArcMAP), the second zoomed in and showing features appearing, and the third as the image should look when zoomed out - in this case I was at 1:3,000 scale. When I zoom out, the image more or less 'disappears' as in the first image.

My friend Google has failed me this time, so I would dearly like to hear from anyone who can explain what is happening and hopefully educate me with a solution. 

Thanks. I will appreciate any responses and especially assistance to resolve this apparent gap in my understanding.

0 Kudos
8 Replies
BrettDavies
New Contributor II

Oops - the three files now uploaded. I had TIFFs before and the uploader doesn't appear to like them... Sorry.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

Hi Brett,

When you created the pyramids, what did you specify for the Pyramid Resampling Technique and Pyramid Compression Type?

Also, what type of stretch do you have applied to the raster?  Using the Image Analysis Window, you can quickly change the stretch type of the raster to see if this improves the display.

Any chance you can zip and upload the actual image?

BrettDavies
New Contributor II

Hi Jake,

Thanks for the quick response. Just a quick note: I'm currently in Western Australia and its just turned midnight, so I won't be here long!

I usually choose cubic convolution for raster images and did so this time. I'm sorry, but I didn't select a compression type for pyramids (not really sure what that is) and just left the defaults in place. I'm running 10.4.1 Basic.

The images are hundreds of megabytes each and complex, so zipping probably won't make for particularly small files - I'm guessing. I will have a look to see what sizes I can produce and will try to upload one here (if that's possible), but won't do so until after the sun rises again in about seven hours.

I have fiddled with the various tools in the image analysis window. Thought that I'd fixed the issue, and then zoomed out back to where I started and as illustrated in the attachments I sent.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

If the raster is too large to upload, you can use the Clip tool within the Data Management toolbox to clip the raster dataset.

0 Kudos
BrettDavies
New Contributor II

Hi Jake,

Thanks. Will do this later today. Would you please remind me where to go to upload?

Cheers

0 Kudos
JakeSkinner
Esri Esteemed Contributor

When replying click on 'Use advanced editor' at the top right of the message.  There you will see an option to attach files.

0 Kudos
BrettDavies
New Contributor II

Hi Jake,

I have clipped the raster, and frighteningly, the clipped data displays as it should! Hmmm... 

I want to attach the clipped raster, but I'm sorry - it's approaching midnight again - I don't see any 'Use Advanced Editor' option associated with these messages (top right or anywhere - I think I'm just tired). Need my hand held again...

0 Kudos
JakeSkinner
Esri Esteemed Contributor

I would recommend running the Copy Raster tool to create a new raster.  This may fix the issue.