AnsweredAssumed Answered

Script editor / PyScripter doesn't open from ArcGIS Pro

Question asked by mboeringa2010 on Aug 4, 2016
Latest reply on Aug 4, 2016 by Dan_Patterson

Hi all,

 

I have tried to get PyScripter running as part of the ArcGIS Pro 1.3 python scripting environment, and especially to be able to launch it by right-clicking a script in a toolbox in Pro (note: toolbox originally created in ArcMap), and choosing "Edit". I have also tried to launch it from the Script Properties dialog, and specifically to edit a Toolvalidator script by choosing "Validation" and "Open in Script Editor". Neither of these options seems to work, PyScripter is simply not being launched, nothing happens except a very short temporary "activity" mouse indicator.

 

Of course, I pointed Pro to the right executable by setting the "Script Editor" option of the "Geoprocessing" option in Pro. It currently points to the pyscripter.exe of the PyScripter V2.60 64-bit install, which is supposed to be compatible with python 3.4, but I have also attempted it with the 32-bit version, and the "portable" one that doesn't require installation. None of this works.

 

Anyone who has had success launching PyScripter from within Pro 1.3? I have no problem doing the same thing from ArcMap. PyScripter launches reliably from there.

 

Marco

Outcomes