AnsweredAssumed Answered

Index passed was not within the valid range error running Level DEM

Question asked by jrolson on Jul 20, 2016
Latest reply on Feb 1, 2018 by Archaeojp

When I try to run Level DEM on the San Marcos tutorial data I get the error message:

“Level DEM: System.Runtime.lnteropServices.COMException (Ox80040202): The index passed was not within the valid range. at ESRI.ArcGIS.Geodatabase.lFeature.set_ Value(lnt.32 Index, Object Value) at ESRI.APWR.ApHydro.ArcHydroOp.LevelDEM(ApLayers apLayers, lnt64 intFactor, String fillField, Double zUnitFactor, DoublefillElevOffse~ lnt.32 debug, ITrackCancel& trackcancel, IGPMessages& messages, String& exMessage) in C:\ Builds\HydroSolutions\ 10.3 ArcHydro\ Sources\ArcHydro Tools\ src\ApHydro\ArcHydroOp.vb:line 1002S”

 

I followed the inputs given in the tutorial (using elev_cm as Raw DEM, NHDWaterbody as Lake Poly, Fill Elevation set to “none”, and offset set to 0). I followed all of the usual ArcHydro conventions (placed data in a relatively short and direct path, started from a fresh map, bringing in the DEM first, etc.). I tried this on two machines, one running ArcGIS 10.1, the other running 10.3, each with a fresh install of the latest ArcHydro builds with the same result. DEM reconditioning works fine, but I was curious to how Level DEM would perform. Any hints on what I might have overlooked?

Outcomes