AnsweredAssumed Answered

Web AppBuilder v2 Installation Error

Question asked by jestanford on Apr 4, 2016
Latest reply on May 31, 2017 by rastrauch

Hi,

I've downloaded and extracted the latest version of WAB but when I run startup.bat I get the following error:

 

fs.js:653

  return binding.mkdir(pathModule._makeLong(path),

                 ^

Error: EPERM, operation not permitted 'C:\Program Files\WebAppBuilderForArcGIS\server\logs'

    at Object.fs.mkdirSync (fs.js:653:18)

    at Object.<anonymous> (C:\Program Files\WebAppBuilderForArcGIS\server\server.js:73:6)

    at Module._compile (module.js:456:26)

    at Object.Module._extensions..js (module.js:474:10)

    at Module.load (module.js:356:32)

    at Function.Module._load (module.js:312:12)

    at Function.Module.runMain (module.js:497:10)

    at startup (node.js:119:16)

    at node.js:906:3

Press any key to continue . . .

 

I thought maybe it was a permissions problem so I ran startup.bat as an administrator and now I simply get the error:

 

"server" directory does not exist

Press any key to continue . . .

 

The server directory definitely exists. It contains 17 files and 3 directories. I've deleted everything and downloaded a fresh copy but still get the same error. Node.js is installed from a previous version of WAB.

 

Ideas?

 

Thanks!

Jill

Outcomes