WAB Template not updating Apps built on template

632
4
05-25-2017 09:02 AM
JeffPace
MVP Regular Contributor

So maybe I am not understanding how the templates work.

I built a template in Portal (with a blank bookmark widget in it).  I then went into Portal and created a configurable app based on that template.

I then went back to my template and added a bunch of bookmarks (configured the widget).  I re 

"export as template" and choose the update option.  It says the template updated.

I then go back to my app, but the changes do not show up.  Other changes (such as which items are configurable) do propogate, but widget configurations do not seem to.

This is the main reason would would use the template, to add new default widgets, to configure widgets, etc..  Am i using this wrong?

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   My guess is you would have to create a new app based on the template to see those changes.

0 Kudos
JeffPace
MVP Regular Contributor

Ok, to be blunt, that's just dumb.  Whats the point of using a template if its static and changes don't propagate?  If i change the "configurable items", those changes propagate.  

0 Kudos
JeffPace
MVP Regular Contributor

The main problem with this is that generates a new appid, which breaks existing links.  I need a way to update the app, in place, without deleting and recreating it.

0 Kudos
DavidColey
Frequent Contributor

No you still have to update your app too with your changes, whether it's overwriting Widget.js or configs.  I've yet to find another way.  I just treat it as a constraint I have deal with.  Unless I too am missing something.

0 Kudos