AnsweredAssumed Answered

64/32 bit problem with external data connections

Question asked by asandres on Feb 26, 2016
Latest reply on Feb 26, 2016 by asandres

Have you has solved this problem?  I would appreciate hearing from you.  Specifics follow…..

I have a Win7 x64 machine with functional 64 and 32 bit Oracle 12.1.0.2 run-time clients complete with functioning ODBC and OLEDB drivers.  Did everything recommended by Microsoft, Oracle, and “BIG TIP for ArcGIS/ODBC/OLEDB users on 64 bit Windows” post on GeoNet.  ArcCatalog will not create a connection to Oracle. 

 

The 32 and 64 bit clients support SQL*Plus, SQL*Developer, and ODBC.     The 64 bit ODBC runs connections for 64 bit MS Office. Path and TNS_Admin environment variables are pointing to the appropriate home, bin and network/admin folders.  The 32-bit oracle client and ODBC connection have been named to clearly indicate that they are 32 bit.  This eliminates any confusion about what client is being invoked when configuring services.  The ODBCad32.exe in the syswow64 folder (see “BIG TIP…” post) creates a working connection to my oracle server. 

 

My oracle db is using TCP and TNSnames and default port 1521:

 

  # tnsnames.ora Network Configuration File: \app\client\asa32\product\12.1.0\client_1\network\admin\tnsnames.ora

# Generated by Oracle configuration tools.

db32 =

(DESCRIPTION =

    (ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = server1.domain1.edu)(PORT = 1521))

    )

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = db1.domain1.edu)

    )

  )

 

The add database connection only allows a choice of “Oracle” for the database platform box.  It does not display specific information about the ODBC connection or Oracle driver in the instance box. Database authentication is used for all.

The ArcCatalog add database connection dialog will not connect to the Oracle server with any variation tried so far:

When instance is defined as db1:  Failed to connect to the specified server.  Do you want to continue? Underlying DBMS error (unknown errorNo extended error.]

 

When instance is defined as db1.domain1.edu:  ORA-12154 (TNS:could not resolve the connect identifier…]

 

When instance is defined as the alias “db32”: ORA-12154 (TNS:could not resolve the connect identifier…]

 

Following the naming advice in the on line help instance set to “server1/db32”:  Failed to connect to the specified server.  Do you want to continue? Failure to access the DBMS server

 

I would appreciate hearing how you would fill in the entries of the Database Connection dialog given the tnsnames.ora shown above or if you think this post should be tagged differently. thanks!

Outcomes