MS Access queries in ArcMap 10 not working

1875
3
02-26-2016 06:37 AM
Highlighted
New Contributor II

Hello. I recently learned that I can add MS access( I use MS access 2010 but have the older versions) queries into Arcmap(I use version 10). In Access I create a query joining 2 tables. Then I create a custom field using SQL to combine 2 fields(text with a numerical). The query works in access. Then I bring the query into Arc10 via database connection and the custom field is populated with the word blob instead of the value. So I tested it using an older version of MS Access(.mdb vs .accdb) and this works in arc10. I don't get the blob value. The field I create in MS access 2010 and 2007 is combining 2 fields and giving me a value as this example: X-9999, a letter, dash and number.

Is there a way around this in MS 2010 or arc wherever the problem is occurring? Id rather use MS access 2010 but there must be a reason if it works in an older version and not the new version

Im new to this site and hopefully positing into the correct forum, its slightly confusing on my first day but it is VERY helpful

Thanks for any feedback

Reply
0 Kudos
3 Replies
Highlighted
Esteemed Contributor

Are you trying this in ArcGIS Desktop 10.0?  If so, can you attempt this on a more recent version of the software (if possible) as 10.4 has just been released, but I think this capability was introduced after 10.0 (Not sure of the version though as there was 10.1, 10.2, and 10.3 with .1 releases as well).

Reply
0 Kudos
Highlighted
MVP Notable Contributor

For 'newer' versions of MS Access (using the .accdb extension instead of the .mdb), you might need to establish an Ole DB connection. There is an esri article on it:

32976 - Connect to Microsoft Access 2007 / 2010 (ACCDB) files in ArcGIS

Reply
0 Kudos
Highlighted
New Contributor II

Yes. I am  creating the OLE DB Connection for the .accdb connection.

My work has not upgraded to the newer 10.2, 10.3 versions yet. I could prob get a copy but the users would still be using the 10 version. I assume if it works with the older .mdb format that this will work for now but I just thought if it worked on an older version that it should work on a newer, and I wasn't familiar with the blob term but I googled it to see.

Reply
0 Kudos