AnsweredAssumed Answered

Web Application Builder url http/https

Question asked by robharris on Feb 25, 2016
Latest reply on Aug 11, 2016 by robharris

Hi, sorry for the long winded question but here goes...

I have Server 10.3.1 with Portal for ArcGIS 10.3.1. installed behind a firewall.

I have configured ArcServer with LDAP Authentication

I have configured the arcserver web adaptor with anonymous

I have published the portal web adaptor with windows authentication


I created a map in portal. All of the services require https. Very simply, when I create a web application from the map using web appbuilder, it automatically creates a link with an http at the beginning. See below:

http://ourmachinename.ourdomain.local/portal/apps/webappviewer/index.html?id=thismapsid (its behind our firewall, I removed any reference to our domain information)

When I initially launch the app, it is an https link.

After the launch, when I view the url it is an http link.  However every time I try to save the new link the changes won't stay. It doesn't matter if I'm logged in as site admin or as myself (Also admin). Basically, I want to share this application as a featured map and app, but when any end user tries to access it they receive a 

403 - Forbidden: Access is denied.

You do not have permission to view this directory or page using the credentials that you supplied.


Is there a way to override the http setting for the applications?


I'm not a developer, I'm just testing portal configurations on a test box. Hoping to stay OOB as much as possible.