AnsweredAssumed Answered

Strange locator behaviour using multiline input

Question asked by phanmore on Feb 8, 2016
Latest reply on Feb 12, 2016 by sbritt-esristaff

I've been upgrading our existing 10.05 locators to 10.2.2 and thought everything was going well until I published our parcel service to Server 10.2.2.  I'm experiencing unusual behaviour when submitting multiline locator requests both through the REST endpoint and SOAP (through ArcMap batch geocoding).

What I'm seeing is that consistently, the first request for an address will return either the expected results or 'none'.  The next request will return the opposite.  This alternating behaviour is consistent and repeatable.  I have tried rebuilding the locator using our previous 10.05 Single Address locator style as well as the one that comes with 10.2.2 and even tried the ones from 10.3.1 with the same results.

This only seems to occur with our parcel data (it's the only one we publish using the single address style) - our roads locator based on dual range style works fine.  It also works fine when using the single line input - just multiline isn't working.

 

Has anyone else experienced this behaviour?  Any workaround / fix?

Outcomes