AnsweredAssumed Answered

ExceltoTable_conversion error

Question asked by Belton on Jan 22, 2016
Latest reply on Jan 22, 2016 by Belton

I am having a problem with a simple line of python code here -- and I don't know why this is happening. There was a point in time where I did not receive this error, so I know it should work.

 

What I am trying to do:

Every month I get a Tax Data CD from the Tax Office, and I am trying to streamline the process of combining the ownership XLS to the Parcel Shapefile. 

 

I have a program I've written in VB which will allow me to select all the files necessary for the join and run the python script. (this stores the input files to a variable in an .ini file, which the python script reads the variables with ConfigParser()

taxtab.jpg

When I run the script, I get this error message:

 

WARNING *** OLE2 inconsistency: SSCS size is 0 but SSAT size is non-zero

WARNING *** OLE2 inconsistency: SSCS size is 0 but SSAT size is non-zero

Traceback (most recent call last):

  File "C:\Users\anotgrass\Desktop\test.py", line 8, in <module>

    arcpy.ExcelToTable_conversion (XLSInput, tableOutput)

  File "C:\Program Files (x86)\ArcGIS\Desktop10.3\ArcPy\arcpy\conversion.py", line 44, in ExcelToTable

    raise e

ExecuteError:

Traceback (most recent call last):

  File "c:\program files (x86)\arcgis\desktop10.3\ArcToolbox\Scripts\ExcelToTable.py", line 254, in <module>

    arcpy.GetParameterAsText(2))

  File "c:\program files (x86)\arcgis\desktop10.3\ArcToolbox\Scripts\ExcelToTable.py", line 244, in excel_to_table

    row[i] = field.validate_value(row[i], workbook.datemode)

  File "c:\program files (x86)\arcgis\desktop10.3\ArcToolbox\Scripts\ExcelToTable.py", line 100, in validate_value

    value = xlrd.xldate_as_tuple(value, datemode)

  File "C:\Python27\ArcGISx6410.3\lib\site-packages\xlrd\xldate.py", line 80, in xldate_as_tuple

    raise XLDateAmbiguous(xldate)

XLDateAmbiguous: 1.0

 

 

Failed to execute (ExcelToTable).

 

 

I've narrowed the error down to the ExcelToTable conversion, and now have a test script solely for testing this out.

 

 

Basically, I have an XLS file that needs to be converted to a temp.dbf file, which later in the script lets me join the table to the Shapefile and create a new shapefile.

 

When I run this simple script, it creates the temp.DBF file,  but it doesn't finish creating it, and then I get the error message.

 

Does anyone know what is going on?

 

Thanks!

Outcomes