AnsweredAssumed Answered

Import using Oracle datapump using different schema

Question asked by yvesthib on Dec 3, 2015
Latest reply on Dec 4, 2015 by yvesthib

Hi,

 

I need to refresh a complete ArcGIS environment in a lab (data and structure).The SDE referentiel.  Note that in this lab environment, the ArcGIS environment already exist.  I simply drop the schema SDE and other schema that contains spatial data.

 

I want to use an existing environment (DEV) to refresh it.  I think I could quickly export/import the SDE schema and the schema containing the spatial data (AGRMGXD1).

 

Export (SID=SIGMAD)                                Import (SID=SIGMAI)

SDE                                                             SDE

AGRMGXD1                                                AGRMGXL1

 

After importing the data, I must update many tables of the SDE schema because, by example, the column "OWNER" of many tables contains the value "AGRMGXD1" and it must be "AGRMGXL1".  I made a script that search all the value of "AGRMGXD1" and replace it by "AGRMGXD1".

 

Finally, I start the ArcGIS service (esri_sde) and it worked.  On my Workstation, I started ArcCatalog and I connected to the schema AGRMGXL1 (it worked too).  I can see all the tables I imported.  But, when I selected a particular table, I saw the record number but I was unable to see the spatial data (in the preview panel).  I've got no error but it doesn't seem to work.

 

Did I forgot something to do ?    Is my way to do it make sense ?  Please, let me know.

 

Yves

 

NOTE: I know I can do it using SDE commands like sdeexport (from) and sdeimport (to)  but it will take much longer time to do it.  I would like to find a good and short receipe that work!

Outcomes