AnsweredAssumed Answered

LabelLayer Has 'Undefined' label for FeatureLayer with 0 Index

Question asked by chuckf74 on Nov 18, 2015
Latest reply on Nov 18, 2015 by rscheitlin

While attempting to label a feature layer that has the 0 index of a dynamic map service, I was unable to get the labels to properly display.  The displayed label was always "Undefined", but the feature layers at index 1,2, etc. worked just fine for the other layers within the map service.  As a work-around, I added a dummy layer on top to take the zero index and changed my javascript side accordingly.  The map service shows population centers that are filtered by different definition queries but no display scales are set on the mxd side.  I did that in the js side.  So its the same feature class, just restricted by different fields a few times.  The display fields is the same for all of them.  There was no difference between layer 0 and layer 1 in the service except for the definition query in the mxd, yet labels in the 0 layer were undefined and the labels in the 1 layer worked fine.  Maybe this comment will potentially help somebody that runs into the same issue.

Outcomes