AnsweredAssumed Answered

Multiple Search Source not firing

Question asked by mbakerDPS on Oct 29, 2015
Latest reply on Nov 17, 2015 by mbakerDPS

All, I'm trying to get the Search multiple sources | ArcGIS API for JavaScript  sample to work, not sure why when I choose my search source, nothing happens..

 

 

- my search source is a point feature layer on an external server:

https://gisprod.dpsk12.org/arcgis/rest/services/address_master/FeatureServer/0

 

My code looks like this:

 

sources.push({featureLayer: new FeatureLayer("https://gisprod.dpsk12.org/arcgis/rest/services/address_master/FeatureServer/0"),
            searchFields: ["ADDRESS"],
            displayField: "ADDRESS",
            exactMatch: false,
            outFields: ["*"],
            name: "DPS Address",
            placeholder: "123 Smith St",
            maxResults: 6,
            maxSuggestions: 6,

            //Create an InfoTemplate and include three fields
            infoTemplate: new InfoTemplate("Address: ${ADDRESS}"),
            enableSuggestions: true,
            minCharacters: 0
         });

 

(I have also attached the html file I'm working on.)

 

Which looks good to me.

 

But when I use *just* my source, or use *all sources*, no network traffic is generated for my source when input text is entered - but I can see the traffic generated for the other sources (ESRI World Geocoder and Congressional Districts) I've left in the app.

 

The only thing I can figure is I haven't added feature templates, but hoping that isn't required...?

 

Thank you!

Outcomes