AnsweredAssumed Answered

Portal 10.3 Configuration Settings

Question asked by steveway on Aug 19, 2015
Latest reply on Apr 16, 2018 by Ross_Havery

Hi Everyone,


I tried configuring a proxy using the PortalAdmin API by setting {"WebContextURL": "<url string>"}.  The update failed, so i thought nothing more of it, until portal stopped working almost immediately.


It failed, and now Portal starts, but i get a HTTP 404 when trying to navigate to the home folder.  It can see through console, that the HTTP404 is produced by the /sharing/.... request that happens.


The only HTML page i can now get up is the PortalAdmin login, and even my Admin username and password is giving me an error message "You are not authorized to use this resource".


So now, i cannot go into the Portal admin to change any settings, and i cannot go to Portal as a normal user to do anything!


I saw in one file in portal/framework/etc/ that the url i used to change the WebContextURL setting.  I reverted this back, restarted Portal and it is still not working!!


Is there some config placed into Postgres that i can get at to fix this?  I ahve spent half a day trying to resolve this - I have looked in every location & file that has been modified, and nothing is jumping out at me.


Many Thanks,