AnsweredAssumed Answered

"Unable to open the database file : "

Question asked by ngp@actua on Apr 8, 2015
Latest reply on Apr 12, 2015 by ngp@actua

I am trying to test the ArcGIS map to see if it fits the needs of my app. Unfortunately I have encountered a problem when trying to read a geodatabase created with ArcCatalog or a sample downloaded from the internet. I have tried with a developer licence and Basic license but both return the same error.

The error is:

"Unable to open the database file : "

and it it thrown on line :

Geodatabase geodatabase = await Geodatabase.OpenAsync(@"{path}\db.gdb");

 

StackTrace:

StackTrace

"  at RuntimeCoreNet.Interop.HandleException(Boolean retVal)\r\n  

at RuntimeCoreNet.CoreFeatureCache..ctor(String databasePath)\r\n 

at Esri.ArcGISRuntime.Data.Geodatabase..ctor(String path)\r\n 

at Esri.ArcGISRuntime.Data.Geodatabase.OpenAsync(String path)\r\n 

at SmartAssArcGISWPF.MainWindow.<MyMapView_Loaded>d__0.MoveNext() in....

string

Has anyone encountered the same problem and found a solution?

 

The licence for Developer is supposed to contain all functionality, is this one with geodatabase not included?

Outcomes