AnsweredAssumed Answered

Is my Elevation Geoprocessing Service working?

Question asked by dafiter Champion on Feb 24, 2015
Latest reply on Feb 24, 2015 by jgrayson-esristaff

I created an elevation geoprocessing service based on the example video Creating Geoprocessing Services | Esri Video.

  • I ran the StackProfile tool and then published the result to a service.

 

I plugged it into the Elevations Profile template. When I click on a line or draw my own the profile does not appear to be different then the out of box GPServer.

 

ESRI service uses 10m resolution. My data uses 1m. My data is only for a small area(the town I work for).  If I use the measure tool outside my data area I still get a result back. Is this because it uses ESRI data for areas that mine does not cover?

 

The only reference to a elevation profile I can find is in line 15.

 

define(
[],
function() {
  var config = {
    bingMapsKey:"Arrzu_Koi7htDRMIwm6kTe0Nqh8FvVdN17blcaJVTEhn87z-tIYJh2LgBNbJS4fv",   
    units: null,
    helperServices: {
       geometry:{
        url: location.protocol + "//utility.arcgisonline.com/ArcGIS/rest/services/Geometry/GeometryServer"
       },
       printTask: {
        url: location.protocol + "//utility.arcgisonline.com/arcgis/rest/services/Utilities/PrintingTools/GPServer/Export%20Web%20Map%20Task"
       },
       elevationSync:{
         url: location.protocol + "//gis.ashland.or.us/arcgis/rest/services/tools/StackProfile/GPServer"
       },
       geocode: [{
        url: location.protocol + "//geocode.arcgis.com/arcgis/rest/services/World/GeocodeServer"
       }]
    },
    queryForOrg: true
};
  
  // could use a has() test to optionally populate some global
  // property so that the stuff defined is in some global identifier
  //
  // instead, just populate a global, will need to remove the next line when
  // when we remove support for loading modules with dojo.require
  // which will be when we move to Dojo 2.0
  commonConfig = config;
  // instead of using a global, this should probably be added to some namespace...
  // do the templates have a common namespace that they use?


  return config;  
});

Outcomes