AnsweredAssumed Answered

Problem with local dijit trying to access js.arcgis.com

Question asked by geonetadmin on Oct 28, 2013
Original User: mlmiller4

Hi, I'm working on an application which has a number of dijits in it handling things like the Table of Contents, Query box, Geolocation, etc.  All dijits are working fine except for one called Selection.js which creates a "Select-by-Attributes" style form for the user.

When I run the app in Firefox, Firebugs reports a "404 Not Found" error and shows the dijit as pointing to "http://js.arcgis.com/js/dojo/dijit/Selection.js"

All other dijits, however, point to the local host, "http://localhost:52093/Web_App_v4/viewer/js/gis/dijit/DijitNameHere.js"

Does anyone know why the Selection.js would be pointing to http://js.arcgis.com, and not the local host like all other dijits?

I've tried changing Selection.js to other names, like SelectionForm, or mySelection, in order to avoid any possible conflicts with other modules of the JS API, but Firebugs still gives the same message.  I cannot figure out why the domain of this dijit is js.arcgis.com, while all other dijits in the same directory have their domains as the localhost.

I've attached two screenshots: one showing the dijit directory tree, and another showing the error message in Firebugs.  Thanks!

[ATTACH=CONFIG]28657[/ATTACH][ATTACH=CONFIG]28658[/ATTACH]

Outcomes