AnsweredAssumed Answered

Model Builder - Not Nullable Error Suddenly Occurring

Question asked by geonetadmin on May 7, 2012
Latest reply on Jun 1, 2012 by curtvprice
Original User: SStrand

I have a model builder process that has worked flawlessly for about two years now. It takes a .DBF file and modifies field names and redistributes their order. The process is run once a month. Today I ran the newest file and every occasion where a field was added in model builder and the DBF has empty values, it is giving me an error for "Field is Not Nullable."

I understand this is an easy fix by going into each "add field" process and allowing null values, but the entire model is 120+ processes, with at least 1/4 of them being "add field." Also my work computer is extremely slow and once I click "OK" to change a setting in model builder, it has to think for about 20 seconds before allowing me to do anything else.

I have compared this months dbf to others and there are no differences within the table, so previous versions have had no issue with empty values. The only thing I can think of that has changed in the past month is that I have upgraded to the latest service pack.

I just wanted to know if anyone has an idea of what could have happened, and maybe if there is a quick fix to the null value issue. Thanks!