AnsweredAssumed Answered

Model runs from within model but fails from toolbox

Question asked by melissatalley on Nov 5, 2011
Latest reply on Nov 7, 2011 by melissatalley
I have a model which was working when I set it up, but is now failing and I cannot figure out why.

The first step of the model is to copy the input dataset to a new dataset with the current time as part of the file name. When I run the model from within model builder this works fine. When I run it from the toolbox everything says that this happens, and a file is created with the correct name, but something does not work because I am unable to open the shapefile that is created and the model does not perform the functions that need to be preformed supposed to on the created shapefile.

I've worked the model down to try and figure out where it is going wrong, it appears to be as soon as I ask it to edit something on the created shapefile. If all I ask the model to do is copy the shapefile to a new shapefile I am able to open the resulting shapefile.

I'm so frustrated because everything worked fine the day I created the model and I haven't changed anything.

I'm attaching the screenshots of first running the model from the toolbox and then running it from within the model. Both time everything indicates that it worked, but it did not.

Is there some problem editing the shapfile that it causing it to no longer be opened. Or from attempting to edit it?

Outcomes