AnsweredAssumed Answered

error message occurs and no output when trying to extract by attribute

Question asked by kimtheis@yahoo.com on Oct 25, 2011
Hi,
I am a student taking a Principles of GIS course. I am enjoying the course, but I am at the last step in my 8th lab and nothing I try will get this to work.

I am instructed to go to Spatial Analyst/Extraction/Extract by attributes. My input layer is "comb_and" and it appears from a drop down window when I select the input window. Then I am instructed to go to sql and insert the following (which I do as written) "Reclass"=1 AND "elevgd"=2 (I dont use any spaces). I name the output file "extract_comb2" and it gets saved to the default .gbd

After the procedure completes, I get an X on my Extract by Attributes popup window and the error messages say that it wont be able to save because I dont have my overwrite turned on (so i turned it on); it says there is no output (but I go to the default .gdb and can see several attempts at extract_comb(whatever); and the story goes on and on.

I havent a clue. I have tried taking spaces out, changing the location to where i save, changing the name (lots of these); and I cant think of others but i am sure there were other things. When I found the extract files in the default .gdb, I tried to open the attribute table but the selection is grayed out and I am not able to view this.

This is the last step in my lab. Any ideas?
Kim

Just tried running it again, this time using only my mouse and not inputting any characters manually. I still get the same type of error: (this is the error I am getting after I turned on overwrite)

000870 : <value>: Output <value> exists. It will be overwritten.
ArcGIS 10
Description
The specified output already exists. It will be overwritten with the new output created by the tool.

Solution
Specify a different output name if needed.

Outcomes