AnsweredAssumed Answered

Why can't I add datasets to Open Data sites?

Question asked by spkearney on Sep 5, 2014
Latest reply on Aug 21, 2019 by jmathiasGIS



I am trying to get started with an Open Data site and so far getting nowhere!  I am trying to start by simply allowing others to browse the datasets on the open data site and download them.  However, when I add an open data group to the site, it does not seem that any of the datasets have been added to the Open Data site. 


Here is the group I would like to add (it is currently publicly shared, with Open Data access allowed):

There should be two datasets in there, one is a hosted features layers, the other a web map with the same hosted features layer added to it (in case that somehow makes a difference!)


Here is the open data site I would like to add the group datasets to:


I have added the group to the open data site and then tried many different things.  First, if I try to use a widget and add a dataset map widget, I get no list of datasets below the search bar.  Only a spinning wheel (and in Firefox a bouncing scroll bar.  Have tried with Firefox, Safari and Chrome.  Also tried with the open data site set to public or not, as per a related post.)  I have also tried adding a dataset ID, both from a hosted feature ID and from a webmap ID, both with no luck.


If I preview the site and search for a dataset, or browse all datasets, it says that no datasets are found.


Am I missing something, or is the ArcGIS Online Open Data platform still just really buggy?  Our organization was contemplating making a switch from GeoNode over to ArcGIS because we thought it would be less buggy, but so far no luck.  Need a simple solution soon to easily share some simple datasets among diverse project partners!  Any ideas, help or links to other threads would be much appreciated.  Many thanks in advance.