jbarnabe

Identifying and tying back output in Modelbuilder

Discussion created by jbarnabe on Oct 10, 2013
I have built the attached model to run individual viewsheds for each tower location.  Each output is labeled with its unique identifier (Dist_ID) using the %Value% inline variable. I used a mask of the 15 mile buffers in the Viewshed Environment settings to cut the processing time and output down to what I wanted.  Then I extracted just the "visible" (1) pixels and created a polygon from it.  This created tons of little pieces per site, so I had to use dissolve to get them all into one polygon. Then I collected them and merged them at the end.  So this works great and all.....BUT here is the problem.  I need to tie these viewsheds back to their original information so that I can see which viewshed goes with a particular tower.  I can't do a spatial join because some of them overlap and the join may connect the wrong point.  I tried clicking on the Fields environment toggle hoping it would carry over some info, but it didn't.  The ID that I need to connect to my original data is in output names using the %Value%.....but that gets lost after I collect and merge.  Is there something in the environments or some toggle I'm missing that will carry over the values from my unique ID field?  My ultimate goal is to eventually Union these tower viewshed polys with demographic block groups and get an idea of the % of the population that lives within each individual tower area.

Attachments

Outcomes