Feature Layer Hover Widget Version 2.12 - 09/05/19

2380
22
05-12-2019 01:17 PM
Labels (1)

Feature Layer Hover Widget Version 2.12 - 09/05/19

Live Preview Site

This widget allows you to configure a Feature Layer in the map to show its popup when you mouse over the feature.

Fixes and/or enhancements

* Fixed an issue with the settings dialog not showing the layer checked for a previously configured layer.

* Changed setting user interface to disable layer that are not feature layers.

Labels (1)
Attachments
Comments

Robert,

Thanks again for this awesome widget! Is there a way to have the widget only show some of the fields instead of all of them?

Why would you not want to see all the fields a the person configuring the widget?

My customer would only like to see some of the information when hovering over a feature (2 or 3 fields). However, I need the rest of the data for other widgets.

No that is not an option. This widget simply shows the layers configured popup.

OK, thank you!

Thank you so much for your work on this widget. I have hosted this widget in my environment but I am having issues configuring it for use in a WAB app. After I have added the widget, selected an available layer in the 'Choose which layer will show it's popup when hovered over' box and clicking 'OK', when I edit the widget again nothing is selected and the tool does not function after saving and launching the web app. 

Thoughts on this? Any help would be lovely.

Joel,

when I edit the widget again nothing is selected

This is a bug in the current release and will be fixed in the next.

the tool does not function after saving and launching the web app

Now this is not something I am seeing. The tool works only when the layer you have configured has a popup configured in the webMap. Do you have a popup configured for your layer?

Thanks for the response! I do have a popup configured for this layer (and other layers that I have tried), and can click on the features and view the popup without issues.

Joel,

  OK, So when you check that layer in the widgets settings dialog and save your app and click on the Feature layer hover widget and mouse over the feature the poup does not open automatically? Do you have any errors in your web browsers console (F12)?

You are correct, following those steps does not produce an automatic popup.

The console is producing 2 errors when trying to edit it's configuration in WAB, and those are related to 2 photos that seem to be missing in the ..FLHover\images folder. Nothing happens in the console on hover.

Joel,

  Do you have a [install dir]\server\apps\[app#]\configs\FLHover\config__x.json file and what does that file contain for your app? The one on my live preview site looks like this:

{
  "layerId": "ParksFinder_107"
}‍‍‍

I guess the most important question is... Is this layer a Feature Layer or is it just a sub layer of a dynamic map service layer?

Well, this is embarrassing.

The user made maps that I was testing against were using map image layers, and not feature layers. I created a map using the feature layer service and it works just fine. 

Thank you so much for your help, this tool is going to help out users out greatly. 

Joel,

   The latest version of the widget does not allow you to select non-feature layers and has a note about this.

Just curious if this hover capability will be made available outside of the web app builder. I think many would love to see this as a standard feature that you could enable or disable for your story map for certain feature layers.  Similar to Tableau or Leaflet....maybe this is a comment for a different thread .....

Will this work with WAB Dev Edition 2.16?  I have tried and the widget setup works, but the hovering does not.

Krystal,

   Works perfectly for me in 2.16. Have you read the info that this widget is for showing the configured popup for a Feature Layer in your map when hovering over it once the widget is activated?

Yes, I have also deployed it to WAB 2.12 and it works great.  Same web map and layer in 2.16, the widget loads and I can select the layer but the hovering does not work.  You can't see my mouse in the image below but it is hovering over a cluster of points.

Ahh, also I am using feature layers that are sub layers of a map service.  So this may be the issue.  Interesting that it let's me select it and it works in 2.12.

Strange. As I said it works great for me in 2.16. Are there any errors in your browsers web console?

Hi, Robert.  I just wanted to follow up on a question from a previous commenter.  I can envision a scenario in which users might only want to see a portion of the data when hovering.  It would be in situations where they don't want labels on the map, but still want to be able to identify a specific feature before clicking on it to get more detailed information in something like your popup panel.  In this case, it would function similarly to a tooltip for the feature, rather than an alternative way to get all the popup data.

I realize this may be outside of your vision for the widget, but just something to think about for the future.  It would be nice to have functionality like that.

Trying to implement the seetings from this widget into my custom widget, coppied settings folder and manifest properties, but getting error on the widgte configuration page: CustomFeaturelayerChooserFromMap.js?wab_dv=2.8 net::ERR_ABORTED 404 (Not Found),

where is teh trick here?

Thank you,

Laurynas,

   I could not tell you as I do not use any such file.

Version history
Revision #:
1 of 1
Last update:
‎05-12-2019 01:17 PM
Updated by: