Water Distribution Utility Network v2.0

987
4
Jump to solution
07-23-2018 05:18 AM
Labels (1)
MinShin
New Contributor III

Hi,

I am new to ArcGIS but brave enough to try Utility Network Extension.

Is there anyone who followed this guide lately(last week or so)? Can someone confirm everything works here?

Get started with the Water Distribution Utility Network Configuration—Get Started | ArcGIS for Water 

I am failing at publishing step with these logs.

Registered data stores are all valid.

When published by copying utility network data, it works. But I don't think that is how it is supposed to be.

When I publish other normal feature layer, referencing registered data works(pgSQL_addresskr). So I am quite confused. 

I just want to hear from someone who followed the getting started guide and succeeded. 

Thanks.

0 Kudos
1 Solution

Accepted Solutions
HowardCrothers
Esri Contributor

Are you using ArcGIS Pro 2.2 and ArcGIS Enterprise 10.6.1? System requirements—Get Started | ArcGIS for Water Error log looks like you are publishing to a previous version of ArcGIS Enterprise.

View solution in original post

4 Replies
HowardCrothers
Esri Contributor

Are you using ArcGIS Pro 2.2 and ArcGIS Enterprise 10.6.1? System requirements—Get Started | ArcGIS for Water Error log looks like you are publishing to a previous version of ArcGIS Enterprise.

View solution in original post

MinShin
New Contributor III

I just checked. Server is 10.6 and ArcGIS Pro is 2.2.0. I will upgrade the server. 

Here is some more newbie questions. I installed server and portal using Chef cookbook as instructed here.

  1. Do I need to reinstall everything including datastore, web adaptor, portal etc or can I upgrade server only?
  2. Do I need to uninstall everything before upgrading or just run chef to overwrite files?

BTW, I am sincerely curious. Which error indicates this is a system requirement issue? I would like to learn to be able to give back to the community later.

0 Kudos
HowardCrothers
Esri Contributor

I don't use Chef, so I can't answer that one.

But however you upgrade, you need to upgrade all components of ArcGIS Enterprise to 10.6.1 - Upgrade ArcGIS Server—Documentation | ArcGIS Enterprise 

There wasn't a specific error code that indicated the issue, it was that the screenshot you included of the log looked like the log screenshot of an error message posted to another forum - Fail to publish Gas Utility Network and a few other folks have had the same issue recently.

MinShin
New Contributor III

Hi Howard,

It took me a couple of days to get back to this issue. Today I successfully installed 10.6.1 and published Water utility network.  Thanks so much!!!

0 Kudos