wxpython module in the ArcMap Desktop

595
1
05-26-2017 07:08 AM
TomášZigo
New Contributor

Hello, I have trouble with import python  module wx (wxPython). If I run import wx in ArcMap interactive shell, ArcMap crash. I run import wx in ArcCatalog interactive python shell I got error message „ImportError: DLL load failed“.

My software config.:

  • ArcMap 10.4.1.5686,
  • os 32/64 bit Windows 7 Pro,
  • Microsoft Visual C++ 2008 Redistributable Package (x86) ,
  • wxPython3.0-win32-3.0.2.0-py27

If I run import wx in interactive python shell (outside ArcMap/ArcCatalog), import is correct. If I run import on os 64 bit Windows 10, ArcMap 10.4.1.5686, wxPython3.0-win32-3.0.2.0-py27 I don’ t have trouble import wx module in ArcMap interactive python shell and module work correctly (create simple python add-in use wxpython library).

What kind of dependency dll library is missing on os Win 7?

0 Kudos
1 Reply
DanPatterson_Retired
MVP Esteemed Contributor

Not sure , but most references to wxpython are 4 to 7 years old 

https://community.esri.com/search.jspa?q=wxpython

and none specific to your problem, but there might be a gem in there