Workaround: installed package crashing Pro 1.4.1

2647
7
05-31-2017 11:17 AM
ClintonDow1
Occasional Contributor II

There have been a few reports of Pro 1.4.1 crashing after packages which depend on the Jupyter/pyQT packages are installed via conda. This is due to a problematic DLL that shipped with conda which doesn't meet PEP 384. It is easy to fix, simply by deleting or renaming the culprit DLL in your active Pro environment's folder.

In your %ProInstalDir%/bin/Python/envs/arcgispro-py3 folder (or equivalent if you have created additional environments), delete or rename Python3.dll - many people are hesitant to alter DLL files, but in the same folder you will see Python35.dll - this is the one which should be loading and will fix the issue. Once this file has been removed, reopen Pro and it should work as expected. 

This issue has been identified and fixed for Pro 2.0 and will not be a problem going forward. If you continue to experience issues please post to this discussion for additional support.

7 Replies
James_Whitacre
Occasional Contributor

I was having issues with Pro crashing when trying to access a custom script tool and other tools in the Geoprocessing pane. This workaround corrected the issue as ArcGIS Pro is no longer crashing when I try to access the script tool.

What was interesting, though, is that my Python3.dll file was dated May 15, 2017, but the issue only started presenting itself in the last few days.

ClintonDow1
Occasional Contributor II

That was the date that the .dll was compiled for the package which was causing the issue, not necessarily when it was installed in the env. 

0 Kudos
MikeFuller2
New Contributor II

I used the suggested workaround (deleted dll file), and it stopped Pro from crashing, so thank you for that, but I ran into an issue importing pandas in the console, and I wonder if that might be related.

I tried

import pandas

and received the following error: 

Runtime error
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\pandas\__init__.py", line 39, in <module>
from pandas.core.api import *
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\pandas\core\api.py", line 20, in <module>
from pandas.core.reshape import (pivot_simple as pivot, get_dummies,
ImportError: cannot import name 'pivot_simple'

I would appreciate any information on the matter.

Mike

0 Kudos
ClintonDow1
Occasional Contributor II

Good morning Mike,

I just tried to replicate this on a fresh install of 1.4 but was unable:

- Installed 'arcgis' package (installs Python3.dll)

- Error as described above

- Deleted Python3.dll

- Reopened Pro, no error

- 'import pandas' in the Python console in Pro & in python via cmd prompt both imported successfully

I currently have pandas 0.20.1 installed, is yours a different version number?

It may also be another package preventing pandas from updating. My 'conda list' shows:

arcgis                    1.0.1                    py35_1    esri

arcgispro                 2.0                           0    esri

bleach                    1.5.0                    py35_0

colorama                  0.3.9                    py35_0

cycler                    0.10.0                   py35_0

decorator                 4.0.11                   py35_0

entrypoints               0.2.2                    py35_1

freetype                  2.6.3                    vc14_1  [vc14]  esri

future                    0.16.0                   py35_1

html5lib                  0.999                    py35_0

ipykernel                 4.6.1                    py35_0

ipython                   6.1.0                    py35_0

ipython_genutils          0.2.0                    py35_0

ipywidgets                6.0.0                    py35_0

jedi                      0.10.2                   py35_2

jinja2                    2.9.6                    py35_0

jsonschema                2.6.0                    py35_0

jupyter_client            5.0.1                    py35_0

jupyter_core              4.3.0                    py35_0

kerberos-sspi             0.2                      py35_0

libpng                    1.6.27                   vc14_0  [vc14]

markupsafe                0.23                     py35_2

matplotlib                1.5.3              np111py35_0e  [arcgispro]  esri

mistune                   0.7.4                    py35_0

mpmath                    0.19                     py35_1

msinttypes                r26                           2    esri

nbconvert                 5.2.1                    py35_0

nbformat                  4.3.0                    py35_0

netcdf4                   1.2.4                   py35_0e  [arcgispro]  esri

nose                      1.3.7                    py35_1

notebook                  5.0.0                    py35_0

numexpr                   2.6.1              np111py35_0e  [arcgispro]  esri

numpy                     1.11.2                  py35_0e  [arcgispro]  esri

pandas                    0.20.1              np111py35_0

pandocfilters             1.4.1                    py35_0

path.py                   10.3.1                   py35_0

pickleshare               0.7.4                    py35_0

pip                       9.0.1                    py35_1

prompt_toolkit            1.0.14                   py35_0

py                        1.4.34                   py35_0

pygments                  2.2.0                    py35_0

pyparsing                 2.1.4                    py35_0

pypdf2                    1.26.0                     py_2    esri

pytest                    3.1.1                    py35_0

python                    3.5.3                         3

python-dateutil           2.6.0                    py35_0

pytz                      2017.2                   py35_0

pywin32                   220                      py35_2

pyzmq                     16.0.2                   py35_0

requests                  2.14.2                   py35_0

scipy                     0.18.1             np111py35_0e  [arcgispro]  esri

setuptools                27.2.0                   py35_1

simplegeneric             0.8.1                    py35_1

six                       1.10.0                   py35_0

sympy                     1.0                      py35_0

testpath                  0.3.1                    py35_0

tornado                   4.5.1                    py35_0

traitlets                 4.3.2                    py35_0

vs2015_runtime            14.0.25420                    0    esri

wcwidth                   0.1.7                    py35_0

wheel                     0.29.0                   py35_0

widgetsnbextension        2.0.0                    py35_0

win_unicode_console       0.5                      py35_0

xlrd                      1.0.0                    py35_0

xlwt                      1.2.0                    py35_0

zlib                      1.2.8                    vc14_3  [vc14]

Let me know if that helps.

0 Kudos
MikeFuller2
New Contributor II

Thanks for the response! I think I had the same version of pandas, but some

of my other packages might have been out of date. I wound up

uninstalling/reinstalling and now everything is working fine.

SamMontoia1
New Contributor III

I find myself with the same issue.  I am running pandas 0.20.3.  and ArcGIS pro 2.0.  "Import pandas" in Python yields: 

Traceback (most recent call last):
File "<pyshell#0>", line 1, in <module>
import pandas
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\pandas\__init__.py", line 39, in <module>
from pandas.core.api import *
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\pandas\core\api.py", line 20, in <module>
from pandas.core.reshape import (pivot_simple as pivot, get_dummies,
ImportError: cannot import name 'pivot_simple'

I have uninstalled and reinstalled arcgis pro.  Attempted to remove or uninstall pandas using conda. I have tried to find a python3.dll, however it is not as described in the discussion above.

Conda List shows two installs of Pandas 0.20.3 along with a few others.  

0 Kudos
ClintonDow1
Occasional Contributor II

With the way the installer currently works, if you modify files within the Pro folder (ie by updating them with conda) then it won't remove those files when uninstalling. This is because the file hash has changed. So you're seeing two versions of pandas likely because when you reinstalled it laid down an older version beside the updated one that wasn't deleted. 

Its an annoying problem and we're finding ways around it for upcoming versions. Currently you may have to manually delete the %pro%/bin/Python/envs folder when uninstalling to ensure everything is cleaned up, or manually remove that pandas version from the environments lib/site-packages directory.