Python program in ArcMap only progress on click (intermittent issue)

116
2
09-04-2020 11:52 AM
EliseosMucaki
New Contributor III

Recently, many of my Python scripts run through the Python window (in ArcMap v10.8.1) will not progress past the first step unless the Python window is clicked. When run (using the 'execfile' command or when loading the program), only the first step is performed. The notification for that step appears, but is much slower to appear/disappear than normal. The program will then not progress to the next step until the ArcMap window is clicked (the location of this click does not seem to matter). Background processing is enabled.

The problem is not script-related (as it has occurred when using two different Python scripts) nor computer related (as it has occurred on two different systems). Oddly, this issue comes and goes. The same program can be run twice in succession, and the program will progress normally on the second run. Sometimes resetting ArcMap will fix the issue, and sometimes it won't.

Obviously this is a major detriment to my automation efforts, so any help on this matter would be appreciated.

0 Kudos
2 Replies
DavidPike
MVP Regular Contributor

Hi, I'm guessing IDLE or otherwise is disabled by policy? 

0 Kudos
EliseosMucaki
New Contributor III

We are using the standard Python IDE that was added during ArcMap installation. I am unaware how one could disable it, and therefore don't know how to check this. I do know that the "idle.bat" installed by ArcMap does exist and runs when double-clicked.

I do want to re-iterate that these Python scripts run normally, just with this odd "on-click" behavior, and that this behavior will sometimes go away without any change to the code itself (e.g. simply re-running the program until it runs normally, or after resetting ArcMap or the PC entirely).

0 Kudos