Error installing arcgis python library with PIP

2348
4
06-14-2018 11:49 AM
GeordieMoffatt
New Contributor

Hi all, I'm trying to install the arcgis python library using PIP.  I need to use PIP as I'm installing the library to a custom folder for a custom python 2.7.1 environment (SideFX Houdini, not to be confused with an actual python environment) not the system's python install.

This is the error I get:

c:\python27\lib\distutils\dist.py:267: UserWarning: Unknown distribution option: 'long_description_content_type'
warnings.warn(msg)
No handlers could be found for logger "root"
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "c:\users\gemof\appdata\local\temp\pip-install-pztuao\arcgis\setup.py", line 267, in <module>
setup(**kwargs)
File "c:\python27\lib\site-packages\setuptools\__init__.py", line 129, in setup
return distutils.core.setup(**attrs)
File "c:\python27\lib\distutils\core.py", line 151, in setup
dist.run_commands()
File "c:\python27\lib\distutils\dist.py", line 953, in run_commands
self.run_command(cmd)
File "c:\python27\lib\distutils\dist.py", line 972, in run_command
cmd_obj.run()
File "c:\users\gemof\appdata\local\temp\pip-install-pztuao\arcgis\setup.py", line 120, in run
super().run()
TypeError: super() takes at least 1 argument (0 given)

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in c:\users\username\appdata\local\temp\pip-install-pztuao\arcgis\

Any help is appreciated!

TNKS!

G

0 Kudos
4 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Are you using the version of pip that comes with the 2.7 install? the one with ArcMap?

And why are you still using 2.7?  Is it because you need ArcMap and not PRO? or is the package not supported in python 3.6?

If your package has python 3.6 support, then the Anaconda packages that ship with PRO make package management quite easy with either 'conda' or 'pip'.

If your package isn't part of the normal complement, then you might be able to get it from Anaconda Cloud

JoshuaBixby
MVP Esteemed Contributor

From ArcGIS API for Python - System requirements | ArcGIS for Developers:

Python Version

Python 3.5 or later is required to use the ArcGIS API for Python.

I suspect you will have a difficult, if not impossible, time getting the API to install with a Python 2.7.x installation.

GeordieMoffatt
New Contributor

Oh ok thanks, unfortunately a lot of computer graphics packages (Maya, Houdini etc) ship with their own internal python environments which are all stuck on v2.  Guess I'll have to fall back to REST interface.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor
0 Kudos