Can't Remove a Menu in Python Add-in (Answered)

09-30-2014 12:12 PM
New Contributor II



I have a Python add-in with a good amount of buttons and menus. I'm trying to remove a menu using the addin_assistant, but the menu isn't being removed from config.xml. I've tried removing the add-in in ArcMap and re-adding it, but that didn't help.


The process I'm doing:

1. Open the Python Add-in Wizard, browse to my add-in folder.

2. Find the menu. Right click and Remove.

3. Save. Click OK for the backup warning message.

4. The config.xml document date is modified automatically by saving.

5. Open the XML and see that the menu is not removed.


Quick thoughts:

  • I've tried restarting my computer.
  • I've removed buttons successfully.
  • I can't remake the add-in every time I want to remove a menu.
  • Customize Mode -> Delete for the menu (in ArcMap) isn't feasible because this add-in will be distributed to hundreds of users.


Any thoughts? Please let me know if you need more info.






Editing the XML to remove the menu and manually re-installing the add-in via the esri addin file is a viable work around at the moment.

2019 Edit: I realized I never followed up on this. This is marked as a bug -

The workaround is the adjust the config.xml file to remove and add buttons, menus, etc.

0 Kudos
0 Replies