Calling SetLogMetadata(False) from jupyter notebook

153
1
09-13-2021 01:44 PM
SethHoedl
New Contributor

Hi -- running arcgis pro 2.8.2 on windows 10.  I have many functions in a jupyter notebook that run tens of thousands of geoprocessing tools.  The geoprocessing history ends up quite large, slowing down performance.  I've tried to stop logging geoprocessing history from both the geoprocessing options for the project and by calling "SetLogMetadata(False)".  No luck -- still logging each and every geoprocessing tool call.  Any one have the same problem and a fix?

Tags (1)
1 Reply
DylanMcDougall
New Contributor II

Same problem, no fix. You may want to try using SetLogHistory(false) as well, although I can't get either one to work as intended. Maybe the environment is getting reset somehow?

0 Kudos