ArcPy CreateWebLayerSDDraft RunTime Error

10-18-2019 11:22 AM
New Contributor

Circumstances: Running a python script on a remotely on a server for daily web layer updates. No outages, changes to script or infrastructure.

Issue: Arcpy Module CreateWebLayerSDDraft kept causing the same error: Line 105 Runtime Error. ESRI support suggested it was caused by using relative path rather than hard coding an absolute path or needing to store SD files on local machine instead of mapped network drive. Both ideas did not work.

Potential solutions: The problem resolved itself this morning through a couple possible actions, which I can not isolate without duplicating the runtime error.

1. Manually overwriting the web layer through ArcPro GUI project file...OR

2. Making sure you are logged in as the same user in ArcPro desktop on the machine which you're running the script from.

Hope that'll help somebody else avoid a few headaches.

1 Reply
New Contributor II

Hey Scott,

Thanks for posting this solution. I was also getting similar error after successfully running python script everyday for few months! Your post saved my time and I quickly realised that somehow the ArcGIS Pro was not signed in to the enterprise account. Signing in again solved the problem!

0 Kudos