Table Select Not Working

229
6
Jump to solution
04-16-2018 06:41 AM
JohnMcConalogue
New Contributor III

I have created a Feature layer and I want to do a SQL select on the feature layer. To accomplish this I have converted the feature layer to a table using the Create Table tool. Now I am attempting to carry out a SQL select on that table using the Table Select tool.

The problem is that when I go to build the SQL expression, the fields contain no values and are blank, yet in the feature layer the fields contain values.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
DanPatterson_Retired
MVP Esteemed Contributor
6 Replies
DanPatterson_Retired
MVP Esteemed Contributor

According to Table Select it supports

The input can be an INFO, dBASE, or geodatabase table, a feature class, table view, or VPF dataset.

Do you mean a feature layer ? or feature class?

0 Kudos
JohnMcConalogue
New Contributor III

It is a Feature Layer.

I am trying to select certain records from the feature layer, is there another way to do this without converting to a table?

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Why not do it in_memory if you don't want to create a physical table on disk... you can dump it when you are done with it if you are doing this in a script or modelbuilder

0 Kudos
JohnMcConalogue
New Contributor III

doing in model builder but I havent  a clue about In_memory

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor
JohnMcConalogue
New Contributor III

Thanks Dan

0 Kudos