Annotation Labeling Going Very Slowly

5142
5
09-14-2015 08:54 AM
WilliamTrachtman
New Contributor III

I just upgraded to arcview 10.3.1.  The movement of annotation labels stored in the map is extremely slow.  The software and the data is stored on my local machine.  Only the license manager is stored on a server.  Any ideas?

EDIT: In particular, it is when I click on the text annotation itself. Or double click to open up the editor dialog.

0 Kudos
5 Replies
PaulDavidson1
Regular Contributor

Have you rebooted your machine?

This is not meant to sound flippant, and it probably won't correct your issue, but we have had this fix many issues on our systems over the years;  especially related to slowness in ArcView and/or connecting to Enterprise Geodatabases.

Good luck.

0 Kudos
WilliamTrachtman
New Contributor III

Good idea, as I had not done that, but no, it is still very slow.

0 Kudos
PaulVastag
New Contributor III

William - Does your annotation have leader lines?  There is a known bug (starting with 10.2.1) with performance problems happening with annotation that have leader lines.  We are having the same issue, but two of our four users have severe performance problems with leader-line anno (10-15 seconds to select one annotation), while the other two only have minor performance problems (1-2 seconds to select one annotation).

Re: Performance degradation with 10.2.1, specifically labels

0 Kudos
JimCousins
MVP Regular Contributor

I have encountered a similar issue, and the labels included leader lines, and annotation stored in the map. I found increased/acceptable performance by converting to annotation stored in a geodatabase.

Regards,

Jim

WilliamTrachtman
New Contributor III

Yes, I now store all my labels in a geodatabase.  Storing them in a map document is useless as it takes a minute just to select a label, let alone move it.

0 Kudos