Time Enabled Image Service

5377
4
01-22-2013 12:35 PM
Labels (1)
JonathanKressin
New Contributor
Hello,

We have many years of ortho photography that I would like to create a time enabled service for.  I can take each years worth of imagery and add it to a mosaic dataset and verify that it is visible, has statistics/overviews/pyramids built on it and looks good. 

The next part would be to take all of these datasets and load into a master mosaic dataset that includes a year field.  This is where I hit the first problem.  I can't add these datasets as a raster dataset.  When the add rasters method runs, it creates a huge temp file, running me out of diskspace before the rasters finish being added. 

I've tried two different other ways of adding the datasets.  The first is adding them as a table.  This looks like it will work, but the pyramids/overviews/etc don't seem to come with the datasets and the time dataset will not work as an image service.

The other method I tried was to turn each individual mosaic datasets to an image service, and then add each of these image services to a mosaic dataset with the time field.  Unfortunately, even though each of those individual image services works great.  The time enabled dataset again will only show the imagery at the raw imagery scale.

Has anyone else done this and come up with the correct procedure to create a single time-enabled image service?

Thanks!
Jonathan
0 Kudos
4 Replies
PeterBecker
Esri Regular Contributor
The suggest workflow is:
Create for each years (or subset) worth of imagery a mosaic dataset (will call this the source mosaic dataset)
In each source mosaic dataset create suitable overviews and apply any required enhancements clipping etc to remove areas of NoData
Add a field (say YEAR) to each of the source Mosaic datasets and use calculate to fill the appropriate value. (Include the overviews)
Do any required QC for each source mosaic dataset and ensure imagery is displayed at all scales
Create a new Derived Mosaic Dataset
Use the 'Table' Raster type and point to the Source Mosaic Dataset.
  ENSURE THAT YOU TURN OFF 'Update Cell Size Ranges' (Else the system will combine all image based on scales)
(Note in versions before 10.0, the MinPS,MaxPS fields were not copied across so it was necessary to create in the source mosaic datasets a _MinPS and _MaxPS fields. Then after adding to the Derived Mosaic Dataset using calculate to set the MinPS and MaxPS back to the _MinPS and _MaxPS values)

Set the appropriate properties for the Mosaic Dataset including:
   Allowed Compression methods (set JPEG 80 as default)
   Allowed Mosaic Method (Set to ByAttribute, Year, and put a base value in the future  (eg 2050)
   Always Clip the Raster to its Footprints - Yes   
   Footprints may contain NoData - No    (These last two enable the system to optimize by geometrically clipping the data vs looking for NoData
    Use Time - Yes
    Start Time Field - YEAR
    End Time Field -YEAR
In Properties/Index add YEAR as an indexed field (just for to aid performance)

Depending on the overlap of the imagery, you may want to create a new overview, but force the system to create overviews only at a very small scale (Put BasePixel size as say width of the Mosaic Dataset/5000). This is only to help ensure that when zooming to extent the system does not need to open too many different years of overlapping imagery.

You will now find the you can use the different time sliders as well as tools such as timeliner available on the resource Center.
In the above example I was using YEAR which is quite coarse. You could instead. If you have finer details on the dates of the imagery use say AcquisitonDate as a Date field. If each of the images has a range of dates then you can also define say StartDate, EndDate and set the Time properties appropriately.
JenniferRichards
New Contributor

Hi there, 
I have followed the above steps as specified and am receiving this error upon saving and re-opening the derived mosaic dataset: 


Please advise 

Jenn

0 Kudos
PeterBecker
Esri Regular Contributor

Please Include details of the error in a different way. The above link in your message is not accessible.

0 Kudos
JenniferRichards
New Contributor

It displays an ArcMap Drawing Error as follows:

One or more layers failed to draw:

Test4: Image: Function Read Error [Mosaic Function]

Test4: Image: An invalid SQL statement was used.

Test4: Image: An invalid SQL statement was used. [AMD_Test4_CAT] 

Test4: Image: An invalid SQL statement was used. [SELECT ZOrder, LowPS, YEAR, OBJECTID from  AMD_test4_CAT WHERE (( NOT  (( YEAR > 0001/01/01 00:00:00 and YEAR is not null )))) AND MinPS <= 0.00138469048266299 AND MacPS > 0.00138469048262955]

Test4: Footprint: an invalid SQL statement was used. 

Test4: Footprint: an invalid SQL statement was used. [AMD_Test4_CAT]

Test4: Footprint: an invalid SQL statement was used. [SELECT Shape FROM AMD_Test4_CAT WHERE NOT (( "YEAR' > 0001/01/01 00:00:000 and "YEAR" is not null) or ("YEAR" < -001/01/01 00:00:00 and "YEAR" is not null))]

0 Kudos