Build Footprints Cuts Non-Null Values

08-29-2018 02:01 PM
Labels (3)
New Contributor II

I'm trying to use build footprints so null values don't appear in my mosaic dataset. However the result after running build footprints cuts areas that are not null. My rasters are 8bit with YCbCr JPEG compression. How do I find out if something is wrong with my rasters? 

Before running Build Footprints

After running Build Footprints

0 Kudos
2 Replies
Regular Contributor

Hard to say without seeing some of the images. I assume that the images when displayed are positioned correctly and at the correct scale so that there is overlap.

Is the source pre-generated orthos? If so then the the only think I can think of that you have the shrink parameter set. Set this back to 0.

The only other way I have seen this is if the source are on-the-fly generated orthos and you are using the Geometry option, but have a parameter such as the average terrain height, focal length or affine transform parameter incorrectly set in the transform. When doing the recompute footprint by geometry the system attempts to determine the image to ground transform. For this some estimate of the ground height is required so the parameters such as average terrain height are used. If incorrect (Average height too large) then the initial estimate may be much too small and cause this.

New Contributor II

Thanks for your insight, Peter! I appreciate it! It is hard to say without seeing the images.

Source raters are raw. No orthorectification either pre-generated or on-the-fly. I had shrink in build footprints at 0. 

I ended up checking some raters out with reclassify and raster calculator (IsNull). All nodata values are where I would expect them to be. 

Once I calculated stats it looks like the footprints automatically excluded the nodata parts. So I just didn't run build footprints.