WPS Clients - issue with execute operation

929
4
01-16-2012 04:34 AM
timothymurithi
New Contributor
Dear Friends,

Has anyone tested the WPS functionality in 10.1 using non ESRI clients? What are the experiences? I have tested with QGIS WPS plugin, uDig WPS client and Jump WPS clients. In all of them I can access the service metadata and ProcessDescriptions but none is able to execute processes. Your ideas and insight on this issue are welcome. Thank you.

Best Regards,


Timothy Gituma
In der Au 16B, Zimmer Nr.2201
70327, Stuttgart.
Tel: +004917668674686
0 Kudos
4 Replies
YingqiTang
New Contributor
Hi Timothy,

We either didn't have any successful experience using non-Esri client to execute WPS processes from 10.1. Like you mentioned, most of the clients were able to get and parse the process description but all fail when executing. This is mainly due to the fact that WPS is a very flexible specification so everyone has its own way to do things. Our plan is to spend some time on QGIS WPS plugin to better understand the cause of the failure. For uDig WPS client, it's not working in recent release of uDig and there is no new development on it either so we probably won't spend much time on it.

Thanks,
Yingqi   

Dear Friends,

Has anyone tested the WPS functionality in 10.1 using non ESRI clients? What are the experiences? I have tested with QGIS WPS plugin, uDig WPS client and Jump WPS clients. In all of them I can access the service metadata and ProcessDescriptions but none is able to execute processes. Your ideas and insight on this issue are welcome. Thank you.

Best Regards,


Timothy Gituma
In der Au 16B, Zimmer Nr.2201
70327, Stuttgart.
Tel: +004917668674686
0 Kudos
timothymurithi
New Contributor
Hi Yingqi,

Thanks for sharing. Well, I have decided to build my own client based on open layers but maybe I will also look into the QGIS WPS plugin as you have suggested. For now am just using an HTTP client to test the execution of my processes. While editing XML is not my cup of tea, it works without a problem.

On a different note, is there a way of accessing the WPS processes in ArcMap/ArcCatalog applications like we do with other OGC services like WMS, WCS, WFS? I'm interested in combining WPS services from different providers in a geoprocess model using modelbuilder.



Dear Friends,

Has anyone tested the WPS functionality in 10.1 using non ESRI clients? What are the experiences? I have tested with QGIS WPS plugin, uDig WPS client and Jump WPS clients. In all of them I can access the service metadata and ProcessDescriptions but none is able to execute processes. Your ideas and insight on this issue are welcome. Thank you.

Best Regards,


Timothy Gituma
In der Au 16B, Zimmer Nr.2201
70327, Stuttgart.
Tel: +004917668674686
0 Kudos
KyttMacManus
New Contributor II

Hi Tim,

I know it has been a few years and a few releases, but I am not having the same issue with Execute at ArcServer 10.3.1

I am trying to use CuRL to post an XML document with an Input Feature Set Polygon, but with no luck.  Could you possibly post an example XML that you have successfully executed against an ArcServer WPS service?

Thanks so much!

0 Kudos
YingqiTang
New Contributor
Hi Timothy,

Sorry for the long long delay, resource center didn't seem to notify me about the your reply. As for accessing WPS processes in ArcGIS Desktop, we probably won't have such a client in the near future, but 52North is working on a ArcGIS Desktop extension of WPS client, which works exactly as you expect (chaining processes from other WPS or native Esri GP tools etc.). I haven't had a chance to play with it yet, but I will keep you updated on this.

BTW, I have been communicating with the developer of QGIS WPS plugin, and it's recent version 0.82 works a lot better with our WPS, so worth a try. I am also interested in your OpenLayers client too, I wrote one using GeoExt + OpenLayers too.

Thanks,
Yingqi

Hi Yingqi,

Thanks for sharing. Well, I have decided to build my own client based on open layers but maybe I will also look into the QGIS WPS plugin as you have suggested. For now am just using an HTTP client to test the execution of my processes. While editing XML is not my cup of tea, it works without a problem.

On a different note, is there a way of accessing the WPS processes in ArcMap/ArcCatalog applications like we do with other OGC services like WMS, WCS, WFS? I'm interested in combining WPS services from different providers in a geoprocess model using modelbuilder.
0 Kudos