Work with a .csv file in ArcMap

596
2
02-29-2012 04:36 AM
CraigCarsley
Occasional Contributor
I have two tables with a .csv file extension that I need to merge together and ultimately join to a feature class.
I have encountered a few problems thus far:

1.  Table 1 does not open with any data in ArcMap.  Table 2 opens just fine, and both open correctly with Excel.
     a.  Table 1 has a field name which begins with '_'.  Could this be causing the problem?
2.  I've tried doing a Table to Table conversion, exporting the tables to a file geodatabase, but it still creates an empty output for table 1.
3. I've also tried to simply merge the two files, but that just fails with no output at all.

Any ideas?

Thanks!
0 Kudos
2 Replies
SisiYan
Occasional Contributor
It is likely due to the header name. The name convention should follow as this link:http://support.esri.com/en/knowledgebase/techarticles/detail/23087.
You can try renaming the field name. Before you do any geoprocessing with the table, it is best exporting them to a dbf first. If it exports successfully, then we can say that the table are valid for ArcGIS geoprocessing.
Hope this helps.
0 Kudos
CraigCarsley
Occasional Contributor
Thanks Sisi, it certainly did help.
I'm still having trouble with merges and joins; my tables do not carry the information over. 
Merging the tables does not work at all.  So, I tried joining each one to the feature class individually and then merging them.
I thought I had success, but after checking, I saw that the table data didn't join; its fields were populated with <null> values. 
I can't use a dbf file because of its character limitation. 

I've always seemed to have issues with merges and joins.  Any thoughts on what might be happening there?
0 Kudos