Select to view content in your preferred language

Web Mapping Appliction: Geoprocessing Service Error 'PermissionError: [Errno 13] Permission denied

11-11-2019 06:22 AM
New Contributor

Hi all,

I am working on a university project that deals with machine learning.  I have created a script tool that I have successfully executed in ArcGIS Pro and published to ArcGIS Server.  However, when I go to execute the tool in the web mapping application, I receive the following error:

I have published the script tool both as a web tool and a model inside ArcGIS Pro.  In addition, I have tried to clone the environment as instructed in "Deploying custom Python packages for ArcGIS Server."  However, as you see above, the service is running from the default environment rather than the cloned environment.  I am not sure if this is the issue or not.

In addition,  I gave extensive permissions under the folder listed in the error.  Again, I receive the same error.

Thanks in advance for your help!

0 Kudos
0 Replies