Viewshed Analysis

12-16-2020 02:43 PM
New Contributor

I am using ArcMap 10.8.1 and working on an hp Probook 650 G4. I have been attempting to run a viewshed analysis using the Viewshed (3D) tool with zero success. I ran this analysis once before which took about 20 hours to complete, then tried to run another analysis on a different set of roads and after 5 days never got anywhere. I used a roads file that I used the split tool on to create road sections every 250 meters and used a 10 m DEM of the area. When this didn't work after several attempts a coworker used the same files and ran the analysis with success after less than 5 minutes. 

I am wondering if anyone has suggestions to help with this? Is there something I should be aware of that perhaps this computer doesn't have enough ram to run this type of analysis or does this version of ArcMap not do well with this analysis, or even yet could there be a corruption in my computer that is prohibiting this type of analysis from completing? I am trying to understand the issue so if I take my computer to our tech people they can better understand what to look for as a diagnostic tool. Thanks!

0 Kudos
3 Replies
MVP Esteemed Contributor

I am not sure if ArcMap's help has this link but ....

ArcGIS Pro 2.7 system requirements—ArcGIS Pro | Documentation

The link on that page will give you a diagnostic for how well it would run ArcGIS Pro.  I wouldn't even consider good specs that meet the minimum requirements as being remotely useful.  Have a run through and at least you will get an idea.


... sort of retired...
0 Kudos
Esri Contributor


The document below is the minimum requirements for ArcMap 10.8.1. Another suggestion is to make sure you are running the tool on local data, that way you do not have any network issues.

ArcMap Requirements 

0 Kudos
Esri Contributor

Is it crashing at any stage, or just taking an age to run and you're abandoning ship after the 5 days?

Also - are you running it with background processing enabled [Geoprocessing on main menu > Geoprocessing options > is the Background processing "Enable" checked]?

Finally - are all the datasets using the same coordinate systems, and have you tried to use the Viewshed [spatial analysis] tool? 

0 Kudos