Using CreateReplica GP tool to check out tables

1550
1
08-29-2012 12:48 PM
TimTeaford
New Contributor
I am trying to use the CreateReplica geoprocessing tool to check out tables using a "CHECK_OUT" type of replica.  The problem I am having is that my tables get checked out with only their schema -- no data/no records.

I see in the help that there is a parameter called "expand_feature_classes_and_tables". I first tried using the "USE_DEFAULTS" option and the tables would check with just their schema -- no data/no records.  I then tried using the "ALL_ROWS" option and the tables STILL checked out with just their schema -- no data/no records.

I want the tables to check out with all of their data.  Does anyone have any suggestions on how I can do this?
Reply
0 Kudos
1 Reply
TimTeaford
New Contributor
Here is the python code I am using for the CreateReplica geoprocessing tool:

arcpy.CreateReplica_management("'Database Connections\\MySDEConnection.sde\\DB.OWNER.Table1';'Database Connections\\MySDEConnection.sde\\DB.OWNER.Table2'", "CHECK_OUT", "C:\Temp\MyFileGDB.gdb", "MyCheckoutVersion", "FULL", "CHILD_DATA_SENDER", "ALL_ROWS", "DO_NOT_REUSE", "GET_RELATED", "", "DO_NOT_USE_ARCHIVING")

I changed the name of the connection and of the table names to make them generic for this example.

As I said in my first post, the parameter that I have set to "ALL_ROWS" is supposed to check out all rows for both feature classes and tables.  What is happening for me is that it only checks out the schema for the tables -- no data/no records.  I would think that ALL_ROWS should be the default, but it isn't.  The default option for this parameter is "USE_DEFAULTS" which only checks out all rows for feature classes. Check the help for the CreateReplica tool and see for yourself.

I hope this helps you get a better idea of what I am trying to do.

Any suggestions will be greatly appreciated.
Reply
0 Kudos