Unabel to enable background geoprocessing

298
1
Jump to solution
11-12-2012 03:13 AM
MarkFreeman
New Contributor
Hello All,

I'm trying to run a Model in the background, but the "Always run in the foreground" tic box, in the model properties, is greyed out. General background geoprocessing is enabled and I've made sure all of the inputs and outputs are set as parameters and that any sub-models can be run in the background, but no luck. Is there something I'm missing?

The model is relatively complex, with 2 sub-models and some Python being run in Calculate Value tools. There are also two levels of iteration. The outputs are Feature Class' though their names are derived from the inputs and therefore the parameters come out as Derived - would this be a problem? 

I'm using 10.1 sp3 with the 64bit background geoprocessing option.

Many thanks,
Mark
0 Kudos
1 Solution

Accepted Solutions
KevinHibma
Esri Regular Contributor
Mark,

If any tool, (tool, model or script) inside the main model has the checkbox "always run in foreground", than the main model inherits from this. Thats why you see it checked and greyed out.

You'll have to set the checkbox appropriately for your sub-models and scripts. For system tools you cannot set this. Either a tool is capable of running the background or not. Hopefully all the system tools you're using are "background capable"

View solution in original post

1 Reply
KevinHibma
Esri Regular Contributor
Mark,

If any tool, (tool, model or script) inside the main model has the checkbox "always run in foreground", than the main model inherits from this. Thats why you see it checked and greyed out.

You'll have to set the checkbox appropriately for your sub-models and scripts. For system tools you cannot set this. Either a tool is capable of running the background or not. Hopefully all the system tools you're using are "background capable"