The index was either too large or too small -  Map Cache Error

11-07-2012 09:05 PM
New Contributor
Dear Sirs,

we have encountered some problem during map caching process, the error messages are as shown below:

Failed to cache extent: 206639.439105 2662911.235289 210804.241808 2669845.025823 at scale 800 ERROR 999999: Error executing function.
Failed to cache extent: 207337.875709 2666378.659724 210804.770976 2669845.554991 at scale 400 ERROR 999999: Error executing function.
The index was either too large or too small.
Failed to execute (Manage Map Cache Tiles).
Field is not editable.
Failed to execute (ManageMapServerCacheTiles).

I tried to redo map cache for the the extent mentioned but no luck.

The map cache processes were doing fine in Arcgis 10.0, but there are many map cache problems in Arcgis 10.1, this is just part of it. We have many other problems such as cache job crashes, hangs, and so on..

I have another unsolved problem in post

Any help will much appreciated

Thanks, Bryant Lin
0 Kudos
13 Replies
Occasional Contributor II
Got the same issue:
Failed to cache extent: 16589675.818559 -4196447.631855 16590729.952912 -4195753.709303 at scale 564.24858800000004 ;Failed.
Failed to cache extent: 16589675.818559 -4196447.631855 16590729.952912 -4195921.841955 at scale 282.12429400000002 ;Failed.

The cache boundary polygon I used is a 800m x 800m square don't believe it's too small or too large.
0 Kudos
New Contributor

I've got this error in ArcGIS Server 10.1 SP1 when I tried to build map cache using too many area of interest polygons (over 8000). The issue was resolved by using not so many polygons - 2000 was OK.
However, I often get this error when caching on a large scale by large polygon. Sometimes restart helps, sometimes not. The issue is quite unstable...
0 Kudos
New Contributor
I have tried building using only one polygon or few small polygons, all fails at scale below 2000. some of my caching services just crashed without any notice, the process looks like still running, in fact no more tiles created for days..
0 Kudos
by Anonymous User
Not applicable
It might help to delete any lock files in any of the caching folders.  That came from ESRI; I've had mixed results.

I get this error occasionally, and often find that the tiles were created just fine anyway.  I've also had plenty of tiles NOT created after a "successful" cache, so make sure to check for tiles, no matter what the Results message says.
0 Kudos
Occasional Contributor

Hey guy's.

I have started generating a grid over the features to be cached then executing the cache process on the grid featureclass. It adds an additional step, but the results are better. The help for the Grid Index Features tool is here:

I restart the CachingTools service regularly also.

Hope this helps .... MD

0 Kudos
New Contributor

I've just had some success on this (I think).

I had always assumed that the error related to either the cache tiling scheme -or- the Area Of Interest that I was using. Today I found that running a repair geometry on the FGDB source for the cache info resolved this for a number of sites that I had been having issues with (since 2014!!).

We are still on 10.1 SP 1 on Windows.

Hope this helps somebody.

0 Kudos
New Contributor II

The error actually doesn't tell much other than the extent at which the caching fails.

1. Upgrade to 10.1 SP1 Quality Improvement Patch. Many bugs and other issues related to caching have been addressed with this patch.

2. Examine status.gdb created in the cache directory. You can create a copy of status.gdb on your local machine and manually examine 'task status' and 'job status' feature classes by pulling them in ArcMap. These feature classes may convey valuable information (possibly an error) about the extent and level the cache creation is failing. You can then check for the elements in that extent which might be stalling the caching process.

3. The error may also result because of resource limitation on the server. You can experiment by increasing the no. of instances allocated to the Caching tools service. As a general rule the max instances can be n+1 where n is the no. of cores on the server machine.

0 Kudos
Occasional Contributor

"Upgrade to 10.1 SP1 Quality Improvement Patch "-- this got rid of my keep existing cache checkbox!

How can I keep my existing cache when i republish a service without this check box?

I am also getting the dreaded

"failed to cache extent: ...  at scale 480

Field is not editable.

The index was either too large or too small."

was optimistic about this patch until I tried to republish my service and saw the check box to keep the cache was gone.

0 Kudos
New Contributor III

I was having this same issue also and I just wanted to post what solved it for me.

I was using a tilling scheme file to define the levels of detail for the cache.  The full extent of the map document used to create the tilling scheme file covered a very large area (1:10,000,000 scale when the smallest scale I needed was only 1:80,000).  I reset the full extent to cover only the area I needed to cache and recreated the tilling scheme file using that map document which did the trick.


0 Kudos