Snap Tool not making features coincident

697
3
03-15-2013 12:43 PM
by Anonymous User
Not applicable
Hi,
I've been trying out the snap tool in the Editing toolbox (I'm using ArcGIS 10.0 sp4) to try to get a polygon to be coincident with a line feature, but it's not working.
I got inspired to use the tool after watching Python Essentials in ArcGIS (jump to 21:38) http://video.arcgis.com/watch/74/python-essentials-in-arcgis-i-_dash_-an-introduction and I read through the Help - http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Snap/001v00000007000000/ and I found this arcticle on using the Snap tool - http://www.esri.com/news/arcwatch/0412/use-the-snap-geoprocessing-tool-to-automate-editing.html

I have a single polygon in a feature class in a FGDB and a line feature class. I set the input features as the polygon, the line feature class as the Snap Environment and I set the type as Edge and a distance of 100 meters.  I run the tool and the polygon is modified but it is not coincident with the line.
Oddly, both feature classes are projected in UTM Zone 10N, NAD83 but when I enter the distance, unless I enter metres, it defaults to Unknown.

See the attached image to follow what I'm doing and the result.
Anyone else had these problems?  Any suggestions? anyone had this tool work as per the documentation?
Thanks for your help
0 Kudos
3 Replies
MelanieSummers
Occasional Contributor III
Hi Hilary,

You may need run your polygon through the Densify tool before being able to snap it to your line.

Best,
Melanie S.
0 Kudos
NickDeMerchant1
New Contributor II
I am having the same issues with point features not snapping to line features.  The feature class has about 4,500 points, and half of those are snapping, but the other half are not.  The points are moving close to the line, just not coincident.  I have tried running the tool with only the remaining features selected, but the results are the same.
0 Kudos
JohannesBierer
Regular Contributor

The snap tool does sometimes things I don't really understand.

If the lines to snap to are very close together, it seems to snap to none of them ....

Some pictures with other problems. Red is the changed geometry through snap, the line to snap to in black.

The geometry to snap to are parcels, I used snap to vertex and end.

Snap1.jpgSnap2.jpgSnap3.jpg

0 Kudos