Return Table Fields

2607
8
Jump to solution
07-28-2015 06:27 AM
TerryGustafson
Occasional Contributor II

I'm new to this so here goes..  I have created a model in ArcMap that generates a GP service.  I'm locating features along a route.  So there are 3 tables that are created for one position.  I have made each table a Parameter in the model.  the problem is when I generate the GP service I don't want all of the fields to show.  can I edit the Parameters of a GP service or how do I show only the fields I want?

0 Kudos
1 Solution

Accepted Solutions
TerryGustafson
Occasional Contributor II

Yep, I think it was going to work as when I went to generate the GP serve only the fields I wanted were visible.. But once the service was create they all showed up.. Thanks again for the help..

View solution in original post

0 Kudos
8 Replies
WesMiller
Regular Contributor III

Have you tried using the Make Table View tool and setting only the fields you want to visible?ArcGIS Help (10.2, 10.2.1, and 10.2.2)

0 Kudos
TerryGustafson
Occasional Contributor II

When I add the table to view the view gets created with the correct fields I want to show but there is no data in the view..

0 Kudos
WesMiller
Regular Contributor III

At what point are using make table view(beginning or end)? If your doing at the beginning and your gp service is trying to query fields that aren't there it may not be getting any data to show.

0 Kudos
TerryGustafson
Occasional Contributor II

Sorry I responded to fast.. I was reading about it and it appears that this is the rule.. So I guess I will try that.. Thanks for the direction!!

if this tool is the last tool in a model, the field names will be obtained from the source data on disk. To maintain new field names, the new layer has to be written out to a new data using Copy Rows<ms-its:c:\program%20files%20(x86)\arcgis\desktop10.2\help\data_management_toolbox.chm::/0017000000n4000000.htm> or Copy Features<ms-its:c:\program%20files%20(x86)\arcgis\desktop10.2\help\data_management_toolbox.chm::/001700000035000000.htm> tools.

0 Kudos
TerryGustafson
Occasional Contributor II

It’s odd.. When I perform the copy rows it creates the table fine and then I perform the Make Table View it creates the view with no data..

0 Kudos
TerryGustafson
Occasional Contributor II

So when I create that new view with just the fields I want should the returned view only have those fields? When I open the view and look at the properties it has all of the fields but the 2 fields I want are the only ones selected. Then when I build the GP service it still puts all of the fields in the table..

0 Kudos
WesMiller
Regular Contributor III

I was worried it would do that, it also does it when your converting to excel. I thought it was at least worth a try.

0 Kudos
TerryGustafson
Occasional Contributor II

Yep, I think it was going to work as when I went to generate the GP serve only the fields I wanted were visible.. But once the service was create they all showed up.. Thanks again for the help..

0 Kudos